Your server is running PHP version but WordPress 3.4.2 requires at least 5.2.4.